Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2013
    Posts
    117

    Default Customize layout issues!

    I created a program with 6 forms (Objects)... I have had all kinds of issues with customizing the layouts on several of the forms....

    The changes are not saved all the time...

    I can run my software multiple times from in ESB and everything if fine but, if I exit out of ESB and relaunch ESB and "run" my project some of the layouts change.

    Also if I customize the layout in my project and everything looks good, then close the project out and do a software build.....install and run it from the exe build.... some editors shift in the layout... It's crazy...

    I have four photos in a tabbed group.... and the never stay the same size... even after doing a exe build and install.... they still are not the same size???

    I have spend hours and hours..... resetting the layoust and starting over multiple times on the same form, changing the layouts arounds....

    Do I need to "lock" the editors in the customization mode? Also after installing the software from the exe build the editors do not resize in the window... when dragging the corner of the window.... This does not happen on all of the form windows when opened..

    I have customers waiting for about 12 days now..... just can't get things right to distribute yet.....

    JIM

  2. #2
    Join Date
    Dec 2008
    Posts
    3,080

    Default

    Hi JIM,


    This is one of those times where I will need to see a video of what you're doing and what happens after you do it.



    Thanks,


    Thomas

  3. #3
    Join Date
    Aug 2013
    Posts
    117

    Default

    Thomas,

    I finally got the layout to work (sort of) just about the way I want it.... Every time I would do a build, things would change when I would install the exe and run it as the end user would do (entry fields would shift, fields would not line up horizontally and extra horizontal spacing between entry field lines etc) .... kept making changes and redoing things and I did about 30 builds before it finally came out right... I hate to go mess with it now....

    My mind wasn't thinking about a video at the time.... I do have a few screen shots... Let me look and see if it shows anything that you could use....

    I am working on something else now and if I have these issues I will definitely do a video!!!

    Thanks
    JIM

  4. #4
    Join Date
    Dec 2008
    Posts
    3,080

    Default

    Quote Originally Posted by Wfjh View Post
    Thomas,

    I finally got the layout to work (sort of) just about the way I want it.... Every time I would do a build, things would change when I would install the exe and run it as the end user would do (entry fields would shift, fields would not line up horizontally and extra horizontal spacing between entry field lines etc) .... kept making changes and redoing things and I did about 30 builds before it finally came out right... I hate to go mess with it now....

    My mind wasn't thinking about a video at the time.... I do have a few screen shots... Let me look and see if it shows anything that you could use....

    I am working on something else now and if I have these issues I will definitely do a video!!!

    Thanks
    JIM
    If you're installing the program to test the layout, I would suggest deleting the app folder within the C:\Users\{YOURUSERNAME]\AppData\Local\Tiger Software\ESB. The folder for your app will have a TS_ and long number. Do not delete C:\Users\{YOURUSERNAME]\AppData\Local\Tiger Software\ESB but the folders with TS will be your install apps created with ESB.

    If you have multiple folders like that then check the datetime on the folder to see which one is the app you just installed.

    I would delete that folder everytime I install just to make things cleaner. At least that is what I do.


    Thomas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may edit your posts
  •