Announcement

Collapse
No announcement yet.

Some editors in the forms disappear BUT theyre still there

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some editors in the forms disappear BUT theyre still there

    Howdy,
    adding this on its own thread..will do that in future..sorry.

    A while ago i mentioned some editors are disappearing but reappear when clicking the label of form.
    So rather then show images i made a quick video (450K).
    Can you tell me if its something to worry about?
    Before i post link just wanted to say it doesnt seem to affect anything though and seems just like an anomolie. It appears to happen..i "THINK" when you delete an editor and add a different one.
    I didi run the repair DB and restarted ..i might check to make sure i am not adding with same name,i don't think so..but will check.
    Here's the video....

    EDIT:

    OK...it seems to happen if you delete a editor from a form and add a new one, that gives this odd
    behaviour. Does it happen for anyone else?
    If you create a FORM from the get-go with 10 editors and run it to test then close program doen & THEN restart you'll see that the FORM with 10 editors is perfectly fine.
    I think (i will retest tomorrow morning..bit late here) if you add more editors to existing form it is FINE
    as well. Its when you DELETE one from the form..then readd another one that the odd disappearing happens.
    Theyre still there (as you can see in video) but not sure what causes it.
    At the end of the day it doesnt appear, as far as i can tell, to create a problem except when you have
    20 and theyre all hidden untill you click it might get confusing..but,,,be nice if others could try it.

    Thanks,
    Robbie

  • #2
    Thanks Robbie. It helps a ton when working through these bugs.

    If the editors are showing up when running the program, it isn't a big deal. Just something quirky with the model editor.


    Thomas

    Comment


    • #3
      Oh yeah...that's one I can confirm also and forgot about - the disappearance of the editors. It happened to me some time ago, and like Robbie, it didn't appear to affect anything, but made it an odd experience when trying to select something in there to edit.

      Mel

      Comment


      • #4
        Originally posted by Mel Bel View Post
        Oh yeah...that's one I can confirm also and forgot about - the disappearance of the editors. It happened to me some time ago, and like Robbie, it didn't appear to affect anything, but made it an odd experience when trying to select something in there to edit.

        Mel
        Mel, did it happen after deleting an editor?


        Thomas

        Comment


        • #5
          Editor Names Disappear?

          Thomas,

          Created a new project in the latest ESB version.

          I created four new FORMS (Objects) and added EDITORS to two of the FORMS (Objects) all of those are OK and shows up.....

          I added 15 to 20 EDITORS to the third FORM (Object) and when I look at the FORM in the designer and expand it.... all of the EDITOR Names are gone except for one of them... When I click on the blue title area of the FORM container or click in the blank area the EDITOR name becomes visible.

          The EDITOR names are there but just not visible...?? This is only happening on the third FORM (Object)

          when I run the software to test, everything is ok and all EDITORS show up and I am able to customize them in the window.

          JIM

          Running ESB as Administrator
          Windows 10

          Comment


          • #6
            Jim,
            that was answered on this thread... http://profittigersystems.com/vbforu...ight=disappear

            I think a search for disappear shows a few more threads but just need to click name (blue area).
            Mel noticed it too but it doesnt affect the workings..just a weird quirk...
            Robbie

            Comment


            • #7
              Originally posted by Wfjh View Post
              Thomas,

              Created a new project in the latest ESB version.

              I created four new FORMS (Objects) and added EDITORS to two of the FORMS (Objects) all of those are OK and shows up.....

              I added 15 to 20 EDITORS to the third FORM (Object) and when I look at the FORM in the designer and expand it.... all of the EDITOR Names are gone except for one of them... When I click on the blue title area of the FORM container or click in the blank area the EDITOR name becomes visible.

              The EDITOR names are there but just not visible...?? This is only happening on the third FORM (Object)

              when I run the software to test, everything is ok and all EDITORS show up and I am able to customize them in the window.

              JIM

              Running ESB as Administrator
              Windows 10
              JIM, was the Form collapsed when you added the editors?


              Thanks,


              Thomas

              Comment


              • #8
                Sorry, Thomas, I was just reviewing this thread and noticed you had a question for me from a month ago.

                Yes, that's when it happened for me. I would delete an editor and then it seemed to mess up the visibility of other editors in the list.

                That's what I remember, but it's been awhile.

                Mel


                Originally posted by TigerSoftware View Post
                Mel, did it happen after deleting an editor?


                Thomas

                Comment


                • #9
                  Originally posted by TigerSoftware View Post
                  JIM, was the Form collapsed when you added the editors?


                  Thanks,


                  Thomas
                  Yes, it was collapsed but, expanded as I added editors....
                  Also I did not delete any forms or editors during the creating process.

                  If I click in the blue area it advances through the list of EDITORS making the Titles visible one at a time. But, clicking on the one EDITOR Title that is visible it disappears. I have to hit the Edit button to view which EDITOR I am one.. Makes it difficult to find the correct EDITOR to go back and add items to a dropdown menus, Radio Buttons etc...

                  JIM
                  Last edited by Wfjh; 03-08-2017, 05:42 PM.

                  Comment


                  • #10
                    I dont know where this is going. I showed screen shots in my other thread that THIS is EXACTLY
                    what was happening to me and Mel as well.
                    It appears Thomas is aware of it and it doesnt affect anything when run (as Mel said as well) but
                    i agree that its a pain...but i can live with it as getting the other things fixed and ready is more
                    important. If theres a list of 20+ like i have theres a point where you click it (somewhere i cant rememvber where now..not at pc) but all of them show, until you click somewhere else..lol.
                    But anyway..i happy to live with the anomoly and get the other stuff ready.
                    Cheers

                    Comment


                    • #11
                      Originally posted by Wfjh View Post
                      Yes, it was collapsed but, expanded as I added editors....
                      Also I did not delete any forms or editors during the creating process.

                      If I click in the blue area it advances through the list of EDITORS making the Titles visible one at a time. But, clicking on the one EDITOR Title that is visible it disappears. I have to hit the Edit button to view which EDITOR I am one.. Makes it difficult to find the correct EDITOR to go back and add items to a dropdown menus, Radio Buttons etc...

                      JIM

                      Do all the editors show when you close the project and reopen?


                      Thanks,


                      Thomas

                      Comment


                      • #12
                        Originally posted by TigerSoftware View Post
                        Do all the editors show when you close the project and reopen?


                        Thanks,


                        Thomas
                        No they do not.... I have quit ESB and shut down the computer and restarted.... launched ESB and ran my program and they are still missing...

                        I have ran ESB normal mode and as Administrator also still missing EDITORS...

                        JIM

                        Comment


                        • #13
                          Originally posted by Wfjh View Post
                          No they do not.... I have quit ESB and shut down the computer and restarted.... launched ESB and ran my program and they are still missing...

                          I have ran ESB normal mode and as Administrator also still missing EDITORS...

                          JIM
                          JIM, can you send me your project file? support(at)profittigersystems(dot)com

                          Thanks,


                          Thomas

                          Comment


                          • #14
                            Originally posted by TigerSoftware View Post
                            JIM, can you send me your project file? support(at)profittigersystems(dot)com

                            Thanks,


                            Thomas
                            Just sent it...

                            JIM

                            Comment


                            • #15
                              JIM, there are no editors added to those two forms (Magicbooks and Magicprops).

                              I added an editor to each form, saved and closed down the project. Opened up the project and they are appearing in the forms.

                              Thomas

                              Comment

                              Working...
                              X