Announcement

Collapse
No announcement yet.

Error Message after Installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Message after Installation

    Hi guys, I decided to come back to ESB ;-) Trying to install.

    I installed the Requirements without a problem (thanks for making it so easy, Thomas), and installed the current ESB.

    When I tried to start ESB, I got the following...

    Is there a fix or is it my computer? Thanks!

    Tink

    ************************

    Message :
    Error 301 (Provider v. 4.3.3.34): Character column data exceeds maximum length name(32)
    Error 119 (Provider v. 4.3.3.34): Cannot create table: WebsiteDatabaseObjectDatabases_WebsiteApiProjectOb jectProjects name exceeds maximum of 32 characters for this database.
    <br/>
    StackTrace : at VistaDB.Engine.Core.Database.CreateTable(IVistaDBT ableSchema schema, Boolean exclusive, Boolean readOnly, Boolean createObjects)
    at VistaDB.Engine.Core.DatabaseMetaTable.VistaDB.DDA. IVistaDBDatabase.CreateTable(IVistaDBTableSchema schema, Boolean exclusive, Boolean readOnly)
    at DevExpress.Xpo.DB.Helpers.XPVistaDBDatabase`4.Crea teTable(XPVistaDBTableSchema schema, Boolean exclusive, Boolean readOnly)
    at DevExpress.Xpo.DB.VistaDBConnectionProviderBase.Cr eateTable(DBTable table)
    at DevExpress.Xpo.DB.ConnectionProviderSql.ProcessUpd ateSchema(Boolean skipIfFirstTableNotExists, DBTable[] tables)
    at DevExpress.Xpo.DB.VistaDBConnectionProviderBase.Pr ocessUpdateSchema(Boolean skipIfFirstTableNotExists, DBTable[] tables)
    at DevExpress.Xpo.DB.DataStoreSerializedBase.UpdateSc hema(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
    at DevExpress.Xpo.DB.ConnectionProviderSql.UpdateSche ma(Boolean dontCreateIfFirstTableNotExist, DBTable[] tables)
    at DevExpress.Xpo.SimpleDataLayer.<>c__DisplayClass4. <UpdateSchema>b__3()
    at DevExpress.Xpo.SimpleDataLayer.ReentrancyAndThread SafetyChecked[T](Func`1 action)
    at DevExpress.Xpo.SimpleDataLayer.UpdateSchema(Boolea n dontCreate, XPClassInfo[] types)
    at DevExpress.Xpo.Helpers.DataLayerWrapperS18452.Upda teSchema(Boolean dontCreateIfFirstTableNotExist, XPClassInfo[] types)
    at DevExpress.Xpo.SimpleObjectLayer.UpdateSchema(Bool ean dontCreateIfFirstTableNotExist, XPClassInfo[] types)
    at DevExpress.Xpo.Session.UpdateSchema(Boolean dontCreateIfFirstTableNotExist, XPClassInfo[] types)
    at DevExpress.Xpo.Session.UpdateSchema(Assembly[] assemblies)
    at DevExpress.Xpo.Session.UpdateSchema()
    at TigerSoftware.Data.DefaultConnectionManager.SetDef aultConnection(String dataPath, Boolean CreateDatabaseSchema, String profile)
    at ESB.Program.Main()
    Date :8/31/2018 1:36:08 PM

    **************************

  • #2
    Tink, welcome back!

    Is this a new project or a project from the old TSB?


    Thomas

    Comment


    • #3
      Hi T! Glad to be back ;-)

      It is a new project. It happened the first time I tried to start the software after installation

      Comment


      • #4
        BTW - Loved how easy it was to save the error message!

        Comment


        • #5
          Originally posted by TinkBD View Post
          BTW - Loved how easy it was to save the error message!

          Only took ten years to do that!

          Ok, back to the error...

          Did you build forms called WebsiteDatabaseObjectDatabase, WebsiteApiProjectObjectProjects and created a relationship between them?



          Thomas

          Comment


          • #6
            Haven't built anything. The software shows the Error and then never opens ;-) Which is why I thought it might be my elderly machine ;-)

            Comment


            • #7
              Hi Tink, welcome back.
              What OS do you have and secondly do you have Pro or expert?
              I got some cool videos coming out with project files very soon but
              they're with automation. Let me know and nice to see you
              Robbie
              ps: looking at error its odd that its mentioning cant create table..hmm.
              Is it running as administrator?
              You probably uninstalled any old version and reinstalled the new one.
              Id uninstall esb again and try install to a new directory and give it a go (assuming its not starting from get-go)
              If i think of anything else....

              Originally posted by TinkBD View Post
              Haven't built anything. The software shows the Error and then never opens ;-) Which is why I thought it might be my elderly machine ;-)

              Comment


              • #8
                Forgot to also add that if its Win 7 or an older machine just check this image as Mark had a non-related
                issue but it doesn't hurt to check... https://prnt.sc/fyb27f (if its all ok its one thing eliminated anyway)

                Comment


                • #9
                  Originally posted by schmutly View Post
                  Hi Tink, welcome back.


                  Id uninstall esb again and try install to a new directory and give it a go (assuming its not starting from get-go)
                  If i think of anything else....
                  Will start with that. Thanks ;-)

                  Comment


                  • #10
                    Originally posted by schmutly View Post
                    Forgot to also add that if its Win 7 or an older machine just check this image as Mark had a non-related
                    issue but it doesn't hurt to check... https://prnt.sc/fyb27f (if its all ok its one thing eliminated anyway)
                    Will check on that tomorrow, if reinstall doesn't work!

                    Comment


                    • #11
                      Reinstalled into new dir with new dir name... Same error message.

                      My system -- Win 7 Home Premium

                      This is what I have for Windows Features

                      Aug312018-1.jpg

                      So... where do I go from here
                      Attached Files

                      Comment


                      • #12
                        Googled -- win 7 Error 301 (Provider v. 4.3.3.34): Character column data exceeds maximum length name(32) -- and found this... Any thoughts on trying it?

                        https://windowstechies.com/-/en/file...xoClCsQAvD_BwE

                        Comment


                        • #13
                          Can you upgrade to latest net framework and then try?
                          --> https://www.microsoft.com/en-us/down....aspx?id=48137
                          Robbie

                          Comment


                          • #14
                            Just tried to upgrade to latest and got this message

                            .NET Framework 4.6 or a later update is already installed on this computer.

                            Further investigation reveals this:

                            Aug312018-3.jpg


                            I don't have any idea on where to go from here. Thanks for the suggestions/help so far ;-)

                            UPDATE - Did another search and found this. Any thoughts on whether I should try it? At least it is a Microsoft fix...

                            https://www.microsoft.com/en-us/down....aspx?id=30135
                            Last edited by TinkBD; 08-31-2018, 10:07 PM.

                            Comment


                            • #15
                              Howdy,
                              you doing well. Its so odd your error.
                              The frame work side was just to get you up to date with requirements but you
                              seem to be there.
                              So you double click esb icon...it doesn't open but comes up with that error you posted after few seconds?
                              Was that correct? You haven't even chosen a project yet?
                              Im still around for 40 mins...just trying to work it out.
                              The error looks like when you run a project file..thats whats got me, i may be wrong.

                              edit:
                              As far as your machine age that's great specs..should be fine.
                              Running the repair tool should be ok too...it wont hurt. But it may not
                              be related to .net error..






                              Originally posted by TinkBD View Post
                              Just tried to upgrade to latest and got this message

                              .NET Framework 4.6 or a later update is already installed on this computer.

                              Further investigation reveals this:

                              [ATTACH=CONFIG]514[/ATTACH]


                              I don't have any idea on where to go from here. Thanks for the suggestions/help so far ;-)

                              UPDATE - Did another search and found this. Any thoughts on whether I should try it? At least it is a Microsoft fix...

                              https://www.microsoft.com/en-us/down....aspx?id=30135
                              Last edited by schmutly; 08-31-2018, 10:24 PM.

                              Comment

                              Working...
                              X