ESB install error

RolandK

Well-known member
Hello Thomas,

It has been awhile but it has been a bad year. Stroke, rear ended at stop sign broken back requiring surgery, double pneumonia covid from going in and out of hospital for back surgery. Just got out and during my down time thought I would look at ESB again. Problem is I get error when trying to start ESB. So, I tried to uninstall ESB but it just re-installed immediately ith the same problem. So, I tried delete the ESB folder and re-installed. Still error. Need help!!! Thanks!
 

Attachments

  • Esb Install Error.txt
    6.8 KB · Views: 11

TigerSoftware

Administrator
Staff member
Dang Roland! I am really sorry to hear about all of this happening to you. It's been a lousy year all around.

Looking at your error, it seems like something is locking the database. Maybe trying a reboot to remove any locks?

There seems to be some issues with the older version when it comes to the licensing. Not sure why since it hasn't changed. Maybe a windows update is screwing with the older code? Not sure, but I upgraded everything and still trying to get this new version out for beta testing. I'm stuck on a big issue right now, otherwise I would have been able to release it.

I'll try and take a look to see if I can do a quick fix to the older version to get you and others up and running. Try doing a reboot to remove any database locks and see if it helps.

God bless ya Roland. I really hope all the bad stuff is behind you. You certainly deserve better!



Thomas
 

schmutlyBOT

Super Moderator
Staff member
Yeah mate, hang in there wow :O
Puts a big perspective shift on all our little whinges and complaining but going through that and coming out the other end :O
Thats amazing Roland and were hear for ya.
I just wanted to look at the error to see if its something i have had myself. I can't register my copy on windows 10 but if i use Vmware emulation i can so i am still trying to resolve my issue so i can finish up the wp activation plugin.
Have you tried deleting the c:\Users\YourPCName\AppData\Local\Temp folder files?
Maybe rename the c:\Users\YourPCName\AppData\Local\Tiger Software\ <-folder to "Tiger Software Old" and try installing again?
There were recent updates to the Visual c+ 2010 and those other MS distributions?

Its all uphill from here mate...pray th worst is behing us all.

Robbie.
 

TigerSoftware

Administrator
Staff member
The no internet error when it comes to licensing is caused by a change in the .Net framework. Still trying to put together something to get everyone up and running while I finish up the new version.

Stay tuned...


Thomas
 
Hi All. Long time no speak. I am having this issue of not being able to register the software when I open it after installing it on my win 10 machine today. I am posting here to see if this issue has been fixed or a workaround?
 

schmutlyBOT

Super Moderator
Staff member
I had something amiss in my hosts file.
c:\Windows\System32\drivers\etc\hosts.
You'll need to right click run as administrator.....rename it
and try again to activate ESB with your email.
I think that's what did it for me.
Then i renamed it back. Try it.
 

TigerSoftware

Administrator
Staff member
Hi All. Long time no speak. I am having this issue of not being able to register the software when I open it after installing it on my win 10 machine today. I am posting here to see if this issue has been fixed or a workaround?
Hey Richard, great to have you back and dusting off the ole ESB. :)

Microsoft changed something (major) and it screwed up my server call. I made a mistake and didn't properly store that latest production version so now I made this workaround until I can get the new version out.

Download the esbregister file, unzip it and add it to the ESB folder (C:\Program Files (x86)\ESB). Running the esbregister.exe file should register the program. Afterward, you can just run the software as normal. You can leave the esbregister.exe file in the program folder and run it whenever you get a registration error.

Executable: http://easysoftwarebusiness.com/esbregister.zip



Thomas
 
Last edited:

Mel Bel

Super Moderator
Staff member
Read another recent post and ended up coming back to this one...

Thought I would add an explanation about what you wrote above for others to see if they need it...

Anyway, so, for me, when I drop the ESB Fix .exe file into the Programs folder, then get it to register me correctly, when I start ESB and go into the designer and try to drag-n-drop a form into the designer area, ESB immediately shuts down.

But if after dropping in the .exe ESB Fix file and registering, then uninstall ESB and reinstall ESB with the main ESB .exe, the drag-n-drop works for the forms and ESB doesn't shut down.

Hopefully I explained that well enough and it helps, but if someone needs clarification, let me know.

Mel
 

TigerSoftware

Administrator
Staff member
I'm going to create a separate program to register ESB. That way no more issues after it is registered. I apologize for the issues. I really thought the new version would be out by now. So close, yet it won't let me go. Lol

Thomas
 

Mel Bel

Super Moderator
Staff member
No worries, Thomas. It's done when it's done. And it won't be done then anyway. We'll all be testing it at that point and reporting back - but that will be the fun part. :)

Mel
 

TigerSoftware

Administrator
Staff member
your almost there...The lights at the end of the tunnel:sneaky:
question.,
will this affect the way the lic.php file works? just thought i would check

Robbie

This would be for the older version. Just to keep people working while I get the new one out. A separate app to register. No changes on the licensing.


Thomas
 
Last edited:
Top